
Inserting SmartArt GraphicslJD 
In addition to being able to add pictures and clipart, Excel 2007 also 
incorporates a new imaging feature, called SmartArt, to help you add 
color, shape, and emphasis to your data based on a variety of 
predefined graphical formats. 

To add a SmartArt graphic to your worksheet: 

,. �From the Insert tab, find the Illustration section and click the 
SmartArt button. 

2. � In the Choose a SmartArt Graphic dialog window, select the 
category and the type of graphic you want to use. (Your selection 
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Sorting and Filtering Data 
Sorting and Filtering enables you to arrange and display your 
information by value or by custom criteria. 

Sorting 

Sorting allows you to arrange text alphabetically, numbers from high 
to low, even dates in descending order, all to effectively organize your 
information. 

To sort a column of text alphabetically: 

,. Select the column of data you wish to sort. 
2. �From the Home tab, find the Editing section and click the Sort & 

Filter button. 
3. � Select whether to sort from A to Z or from Z to A. Note: When 

sorting numbers, the data is sorted Smallest to Largest, or Largest 
to Smallest. 

Filtering 

Filtering data, text, dates, and more, allows you to display only the 
rows with specific criteria you define. 

To filter data: 

,. �Select the group of cells you want to filter. 
2. � From the Home tab, under the Editing section, click the Sort & 

Filter button, then Filter. 
3. �Click the drop-down arrow G that appears at the top of your 

selection to access the filter criteria settings. 
4. � Select the numbers you want to filter by checking the box(es) next 

to the value(s) you want to include. 

You can also filter by defined criteria when you select the Number 
Filters option. For example, to filter your data to only include values 
less than a specific number: 

,. �Click the drop-down arrow 
that appears at the top of your 
selected column. 

2. �Select Number Filters ILess 
Than. 

3. Use the drop-down arrow to Use 1 to rep,-eser.to!ll'·imgec:MrltCte" 
�u�~ '" to �r �~�@�S�@�!�l�l�t� ¥w series of �d�w�~�t�e�r �:�5select the less than feature. 

4. � Enter a value or select a value 
from the list. 

5. Click OK to filter your data. 

Using PivotTables 
A PivotTable is an interactive table used to quickly manipulate and 
summarize your data. Using simple drag and drop actions, you can 
rotate rows and columns to create summaries of the source data, filter 
source data, and examine data in further detail. 

Creating a PivotTable 

To create a PivotTable, first ensure your source data is clean and 
organized. Columns and rows should be labeled, and no blank rows or 
columns should be present in your selection. 

Row labels 

G H 
1 ; Department Year Sales 
2 �M�~�'�:�l�s�~�l�(�)�t�h�.�i�I�l�9� 2003 12 

3 �M�. �e�n�~�c�;�l�o�t�h�i�n�g� __ �?�~�.�~�~� ... 13.5 
4 �M�~�n�s �. �~�l�o�t�h�i�n�g� 2005 12.8 

2.. Womens Clothing 2003 15 
Womens Clothing 2004 18 �

7 �l�J�\�I �. �o �. �l�T�I�~�n�~�C�l�o�t�h�i�l�l�g� 

8 Cosmetics �
9 Cosmetics �

10 Cosmetics �
11 Footwear 2003 5 �
12 Footwear 2004 5.5 �

2005 
2003 

2005 

.. -+ 
13 Footwear 2005 48 

Column labels 

Source data 

To create a PivotTable: 

,. �From the Insert tab, under the Tables section, click the PivotTable 
button, then PivotTable to open the PivotTable dialog window. 

2. �Select the table or range for your PivotTable and its location in the 
worksheet. 

3. �Click OK to insert your PivotTable. 
Choose fiekls to add to 
report: 

�0 �D�~�p�a�r�t�m�e�n�tThe PivotTable Tools tabs will now display 
([,!lYe., 

on the Ribbon. A PivotTable graphic 10 50105 
placeholder will appear on your worksheet, 

i 

and the PivotTable Field List will display to 
the right of your screen. Selecting fields to 
add to your report will automatically 
change the PivotTable placeholder graphic 
with the data you have selected. 

1. � In the Field List, select the fields you 
want included in your PivotTable report. 

2. �Arrange the look of your report by 
dragging the corresponding fields, such 
as Year or Department, into the 
appropriate report categories. 

3. �The PivotTable will automatically update. 

Working With PivotTable Results 

Source Field:Double-click to Data Fields: Click the drop-down 
change how your data is tabulated arrow and select or deselect the 
(e.g., Sum, Count, Average). fields you want to include 

�~� �~� 
Sum of Sales _____ Column LabelST... 1 

Row Labels 1... 2003 2004 2005 Grand Total 
Cosmetics 
Footwear 

.Mens Clothing 
IWomens ClothinQ 

7 8 7 
5 5.5 4.8 

12 13.5 12.8 
15 18 16 

22 
15.3 
38.3 

49 
Grand Total 39 45 40.6 1f4.6 

-------=��~� 

PivotTable Results: Displays the results ofthe action performed by the 
PivotTable. ln this case, the results display the sum of annual sales by 
department over a three-year period. 



Working With Charts 
Charts are an effective way to provide a rich, visual explanation of data 

Creating a Column Chart 
To create a chart using existing data: 

1. 	Select the cells you want included in your chart. 
2. 	From the Insert tab, under the 

Charts section, click the style of 
2 'John Stevens 

chart you want to create and 3 Ifr'~ 'Y Cramer 


select from the drop-down list .~ · t:~:::~:'rtO n 

of available charting options. 
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3. 	 Your chart will 20,.--. r -----_ __~ 
automatically open 
in your worksheet 

window. The 


.. Jchn St~·f:m. appearance will 
• MillV Cramer 

depend on the U Am'l PlI rk 

• fton And~H.cnchart options you 
selected. 

Millm 

Note: The ChartTools contextual tabs will also appear on the Ribbon, 
providing quick and easy access to design, layout, and formatting 
features for your chart. 

Customizing Chart Design, Layout, and Format 

The Chart Tools Design, Layout, and Format Tabs allow you to further 
customize the look of your chart. 

Customizing Chart Design 

The Design tab provides '~''''''':''."'Jm.. o&.lJiOI, 


access to dozens of chart 

types. 
 ; :: ~~~JKrunw~M l~r:l 

: : IliiJJW~~~[!MJu t 
To change a chart type: E::', IMl~ ,M1~~ 
1. 	From the Design tab, 

select Change Chart Type I§:' II!cc~~JdkjB8~ 
2. 	Make your selection. . 4	 1 ..., 1 ..;:::J ,.,.~~ 
3. 	Click OK. I !!r#lQl' T . J I ~u Dr'.alltl'. 1 I c.E:J ~....io:l 

Customizing Chart Layout 

The Layout tab provides 
options for revamping axis 
titles, legends, and more. Chart FJ(is Legend Data Data I 

Titl e y ntl"s'" Lab els y Table'" 

Customizing Chart Format 

The Format tab has the tools needed to alter specific aspects on your 

Using Formulas 
Formulas calculate speCific values in your spreadsheet and are useful 
in reducing your workload while still ensuring accuracy. 

Writing Formulas 

Formulas begin with an equal sign (=) and are calculated using basic 
mathematical order of operations. For example, items enclosed in 
parentheses are calculated first, then multiplication and division 
operations, followed by addition and subtraction operations, etc. 

Produces a result of 11. Four (4) is multiplied by
=4*2+3 

two (2) and then added to three (3). 

Produces a result of 20.Three (3) is added to two
=4*(2+3) 

(2) and then multiplied by four (4). 

Understanding Functions in Formulas 

Functions perform calculations using values you specify.The structure 
of a function begins with the function name (e.g., SUM, AVERAGE, 
MAX), an open parenthesis, arguments separated by commas, and a 
closing parenthesis. 

All of the function options can be accessed in the Function Library 
located under the Formulas tab. 

...!!t. Text y 

Lookup & Ri'''''rence • 

Math & Trig y 

Function AutoSum Recently Financial ~, . 
\'Vizard • Used . • I:-I Date & T,me· More Functions • 
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Practicing formulas 

Using the grid on the 
right, the following 
samples provide an 
example of how 
formulas work. 

.... 

I ~ 
2

13 
14 , 

A I 
1 
2 
3 

- '41 

B I c 
2 
3 
4 
1 

I 
3 
4 
1 
2 

0 
4 
1 
2 
3 

Equal sign (=) Function Arguments 

begins a ~Ia / na~ 

=SUM(A1,83:84,2) 

Commas separate / p~theses enclose 
each argument 	 arguments 

=SUM(A1 , 83:B4,2) Total values in A 1, B3 through B4,add 2 8 

=AVERAGE(A1 :01 ) Add values in A 1, B1, C1, & D4,divide by 4 2.S 

=81+10*04 Multiply 10 by value in D4, add value in B1 32 

35 =A4/C4+33 Divide value in A4 by value in C4, add 33 

:::(C2+80-3)*04 Add value in C2 to 80, subtract 3, multiply by D4 243 

Understanding Absolute vs. Relative References 

Cell references in formulas change if the formula is copied to another 
cell. For example, if a formula is copied one column to the right, the 
reference of A 1 will change to B1. 

You can make a reference absolute (so it doesn't change) by placing a 
chart, such as dollar sign ($) in front of the reference when creating a formula.~ Shape Fill y 

Shape Styles, 
WordArt Styles,and " B B B =1.t. Shap e Outline·i $A$l Both the column and the row values are absolute 

'I 	 Sh ape Effects $A 1 Only the column value is absolutechart size options. . 	 . yJ · 
I!=====-::--~ 

A$1 Only the row value is absolute 
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Getting External Data 

Importing Data From the Web 

To get external data from the Web for use in your spreadsheet: 

1. 	 From the Data tab, under the Get External Data section, click From 
Web. 

2. 	 The New Web Query dialog window will open automatically. 

.......... _ _ _ :JiI!KJ
Enterthe Use 
""~' .",,,,,,,,,'!!'_ ~~,,-, liJ @ Si~ j !;\ I ~"",,"...URL where navigation0IIII E1.a! "' .... L/'Nrs'jW ........ !~!.dt<;I. ,..e'ld<.iIl«:cn.
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located. M. ~.• . . 
loll :1.1' \~ l-I'> move forward 

and back. 
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Click the !fI=••I!I!!.'.-. ;;;-.'.";;;;"""!..o ::=....III!!I~ ,~'
yellow arrow/ I \£ ~ ....r,,,"-.....Ii~.......!!l!e~~ I 
button [!] : ~; "£.. ; ~t~~~\ :~~~ ~-. 

next to the r.u& :~;:~.: lIQht~blfY~.{JI ~.es.. I_"" " '...a.yr. r' UsetheI: Sot 5 to t:! .-;<> 

table(s) you .,._ ~ _. ~",.;. ..... ,....~. ,_• •~ scrollbars to 
want to add. :=.... .;.....r.'<'4I \ .sll,~ .~ bU ... ... • navigate your 

It will turn " - ' , ~L"': ! Web page. 
I Igreen once 

you click it. 

3. 	Select the table(s) you want to !mpcrtO... 

incorporate and click Import. :Sdo<",'... ,.."·''''tlo ''......_~'..... '''''_.
! 	 W .; r.... 

4. 	 Select how you want to view the i !l2l ",.n_ _ , 
data you import. - :;~::~:::=- R''''''' 

5. 	Determine where you want to '\·...... oo"/Ou ,·'oo"o""' ...o.\., 
pl~ce the imported data. . ~ ~ _ "". i-:.abt""t' __--.:~. 

6. 	 Click OK.The Web data Will now i 0 [;•...,'·,"" - , 

appear in your spreadsheet. i~ ~~ 

Importing Data From Access 

To get external data from an Access database: 

1. 	 From the Data tab, under the Get External Data section, click the 
From Access button. 

2. 	 Search through your files and select the Access file you want to 
import. 

3. 	 Click Open. 

Importing Data From Other Sources 

To get external data from other sources: 

l from SQL SefWf1. 	From the Data tab.. 
Crtilte a conntdion to a SQLServt:r tabl(.lmport d~tllLEI into Exell as a Table or PlvotTable rl!port.under the Get External 
From AnarysisServicesData section, click the Cmltl! it connectl.on to a SQL Server Anal>jsis St:IV'ius (Ube.LQ Import dllt~ into Excd as it Tabr~ or PiY'otTab(e r.eport.From Other Sources 
From XML Oa.ta. Import 

~ Op~n or mllp II XJo.·'L file Into f.xcHbutton. 
2. 	Follow the steps to 

~ 
from Oat&: Connection WtnlC'd 

Import datil for bn uniJsted tormat by USing tho:'! Dataimport your data 
Connection ",Vi za rd and OLEOS. 

From Microson Queryaccording to the option 
in1port d~ti110r an unlisted format by usin~ the ~.!icroso1t~you have selected. Query WiZll rd lind CDSe. 

Importing Data From Existing Connections 

To get external data from other connections: 

1. 	From the Data tab, under the 
Get External Data section, 
click the Existing 
Connections button. 

2. 	Select an available 
connection. 

3. 	 Click Open. 

-

Inserting a Hyperlink 

A hyperlink creates a shortcut to automatically redirect users to a 
network server, intranet, or to open an Internet page. 

To insert a hyperlink: 

1. 	 From the Insert tab, under the Links section, click the Hyperlink 
button. 

2. 	Enter the text you 
want your hyperlink -h.-......r==.."Gi~.-- - ..-._.- - -~ l ,:,:-",· I 

to display.	 · ~~ -- tJ ~ ~1iJI1 1 -.. I 
3. 	 Choose the target for """ 

the link you want to 
create. Note: When 
linking to the Web, ';'':;''';':;-=';' -_----==.. - . ~J__ 
enter the target URL. 

4. Click OK. 

Saving Your Workbook 
Excel 2007 enables you to save your workbook in Excel 97-03 format, 
in Portable Document Format (PDF), or in XML Paper Specification 
(XPS) format. 

To save your workbook: 

1. Click the Office Menu button @. 
2. Click the arrow next to Save As to access all of the Save As features. 
3. Select the type of file you want to save as. 

·~".u..	 ITil·~--------------------------~~4. Determine where to 1,~~·::~""r-... ' rXPS	 ....;.,,:.--=-__~__~~~~===~:::;
OC . """'" ' j ,. ij """" PIsave your file. 

"., ",,".~~~:::::::::::::~5. Enter a filename. s.-.~ .J I)"Fl';I",·f ___~________.c.Jlp "::..	 ~ 

6. 	 Next to the Save as 
type section, click the 
drop-down arrow to 
select the file format Op\lCI>\... I 

you want to use. For 
example, PDF or XPS. 

7. Click Publish (or Save). 
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